Welcome to the IBM Websphere Commerce Hub


Welcome to the IBM Websphere Commerce Hub

Come join me in my journey to explore the various features and capabilities of IBM Websphere Commerce and understand how retailers can benefit from its really cool out-of-box functionality.

Thursday, March 15, 2012

RESOLVED : Unable to access WAS Admin Console

After I tried out the steps to resolve the WC Publishing issue as detailed out in my post -

http://wcs-hub.blogspot.in/2012/03/application-failed-to-install-wc.html

I found that I am unable to access the WAS Admin Console. Each time I try and access using the following URL -

https://localhost:9043/ibm/console/

I could see the following exception in the SystemOut.log -

7/1/09 11:08:49:971 CDT] 00000026 WebContainer E SRVE0255E: A WebGroup/Virtual Host to handle /IBM/console/ has not been defined.
[7/1/09 11:13:41:064 CDT] 00000027 WebContainer E SRVE0255E: A WebGroup/Virtual Host to handle /IBM/console/ has not been defined.
[7/1/09 11:13:56:705 CDT] 00000027 WebContainer E SRVE0255E: A WebGroup/Virtual Host to handle /IBM/console/ has not been defined.
[7/1/09 11:14:15:471 CDT] 00000026 WebContainer E SRVE0255E: A WebGroup/Virtual Host to handle /IBM/console/ has not been defined.
[7/1/09 11:14:30:424 CDT] 00000026 WebContainer E SRVE0255E: A WebGroup/Virtual Host to handle /IBM/console/logon.jsp has not been defined.
[7/1/09 11:14:53:299 CDT] 00000027 WebContainer E SRVE0255E: A WebGroup/Virtual Host to handle /IBM/console/logon.jsp has not been defined.
[7/1/09 11:15:11:939 CDT] 00000027 WebContainer E SRVE0255E: A WebGroup/Virtual Host to handle /IBM/console/ has not been defined.
[7/1/09 11:15:45:236 CDT] 00000026 WebContainer E SRVE0255E: A WebGroup/Virtual Host to handle /IBM/console/ has not been defined.

In Mozilla , I could see the following error -


I searched a lot of forums but no concrete solution. I found this suggestion in a forum which may work out for you (thought it did work for me! ) -

The problem has been fixed by executing this script: ${WAS_HOME}/bin/iscdeploy.bat -restore

I then went on to compare the folders which we had backed up in the previous post

- WCDE_installdir/wasprofile/config/cells/localhost/cus
- WCDE_installdir/wasprofile/config/cells/localhost/blas
- WCDE_installdir/wasprofile/temp

I found only the "WC" module has been restored and all other modules listed below are missing -
  • ibmasyncrsp
  •  IBMUTC
  •  isclite
  •  soccom
If the same is the case for you , just restore the missing module folders from the backup and restart the server. The WAS Admin Console will be up and running!



3 comments:

  1. Great!! you helped me a lot. Thanks

    ReplyDelete
  2. Thanks Neha, your blogs have always been superb :) Thanks a ton!!

    ReplyDelete